Escolha uma Página

Olá Pessoal!

Outro dia tive a necessidade de identificar em uma coluna do Excel um CONTADOR, contudo, se fizesse manualmente, ao excluir uma linha teria de refazer novamente a coluna de contagem…

Como adicionar coluna com contador automático no Excel??

Tive a seguinte ideia, talvez alguém já fez algo melhor… mas pra mim funcionou!

Passo a passo:

1. Criamos uma tabela pré-formatada – clique aqui para saber como criar uma tabela pré-formatada

2. Na primeira coluna renomeamos o título para ‘COUNT’

3. Na primeira linha da primeira coluna (A2) colocamos a seguinte fórmula:

=SE(ÉNÚM(DESLOC(A2;-1;0));DESLOC(A2;-1;0)+1;1)

Repare que a coluna se referencia a ela mesmo dentro da fórmula na célula A2, assim sendo, ainda que exclua uma linha não irá impactar a fórmula!!

Segue modelo de exemplo:

Modelo de Planilha com Contador Automático em coluna de Tabela Pré-Formatada

 

Segue como ficou o resultado final:

 

Contador Automático

 

Dúvida ou sugestões entre em contato pelo site, comentários abaixo ou pelo e-mail tigor@excelguru.com.br